Wednesday, December 24, 2014

How to fix no sound on Ubuntu 14.04, 13.10, 13.04 and Older versions

I am a huge fan and user of Linux operating system (OS) especially Ubuntu. And like any other Linux OS, I often find myself trying fix something or other after installing the OS. In particular, I would find myself trying to fix NO SOUND problem. I have found several steps that can help anyone having NO SOUND problem with their Linux OS.

  1. Check your volume. By clicking on the speaker icon on the toolbar or opening system setting->Sound Settings, you should be able to adjust your system volume. Sometime user tends to over look this obvious mistakes.
    Check your volume
    Volume Setting
    Linux Volume Setting
    Linux Volume Setting
  2. Check your ALSA Mixer.
    PulseAudio controls underlying ALSA-level volume controls. To change the ALSA-level volume controls directly, you can do the following:
    Open a terminal. (The quickest way is the Ctrl-Alt-T shortcut)
    Enter �alsamixer� and press the Enter key.
    You will now see a user interface like below.

    alsamixer
    ALSA Mixer

    In this user interface, you can do the following:

    1. Select your correct sound card using F6 and select F5 to see recording controls as well
    2. Move around with left and right arrow keys.
    3. Increase and decrease volume with up and down arrow keys.
    4. Mute/Unmute with the �M� key. An �MM� means muted, and �OO� means unmuted.
    5. Exit from alsamixer with the Esc key.

    A caveat here: When you mute or unmute something, pulseaudio might pick it up and mute and unmute other controls, as well as PulseAudio�s main mute.
  3. Reinstall Alsa and Pulse Audio.
    Try to reinstall pulse audio and Alsa, open terminal and enter the following commands:

    Purge Alsa and Pulse audio using the command:
    sudo apt-get remove --purge alsa-base pulseaudio
     
    Now install again Alsa and Pulse Audio:
    sudo apt-get install alsa-base pulseaudio
     
    Then, reload Alsa:
    sudo alsa force-reload

    Done. Check now the sound if it is working, if not, try step 4.
  4. Install Ubuntu Audio Development Team Driver

    Note: This PPA is not updated to 14.04 yet.

    Upgrading your sound drivers may fix the nosound issue, you will need to make sure to uninstall the previous override before trying a new one.
    Open terminal and enter the following PPA:
     sudo add-apt-repository ppa:ubuntu-audio-dev
    sudo apt-get update
    sudo apt-get dist-upgrade 
     
  5. If all else fails, try the following command.

    alsactl -F restore 
Hope this helps someone. That's all for now....Cheers...

No comments:

Post a Comment